SOLVED : Openfire Server Administrator Password doesn't work after install

I'm got this error after installing Openfire Server 3.6.4 on my Ubuntu 10.04 LTS,

this problem occur after i finished installing Openfire, i could't able to logon to the admin console, I remember the password but it's doesn't work, Openfire says Login failed: make sure your username and password are correct and that you're an admin or moderator.

I'm so confused, until I found the solution

If you have this problem you can try this

1. Make sure you have php5-mcrypt installed, if not installed you can install it from terminal (sudo apt-get install php5-mcrypt)



2. After you finish installing Openfire do not directly login to Admin Console, firts you must restart the openfire service, you can do that by typing sudo service openfire restart in terminal.


3. Make sure you don't use unicode caracter in your password, use only standart caracter.


4. The last is Restart your System  and I guarantee that everything is OK

If you want to reconfigure the Openfire installation, you can do this by editing the Openfire.xml (sudo gedit /etc/openfire/openfire.xml, and change the <setup>true</setup> to <setup>false</setup> restart openfire services and run setup again.

hopefully useful.... :)

2 Response to "SOLVED : Openfire Server Administrator Password doesn't work after install"

  1. Jeston 27 Juli 2010 20.12
    it's work for me :)
    just follow these step from beginning
  2. Aditya's 27 Juli 2010 22.27
    OK,
    happy to help you :)